ssf logo blue Rötter - din källa för släktforskning driven av Sveriges Släktforskarförbund
ssf logo blue Rötter - din källa för släktforskning

Choose language:
Anbytarforum

Författare Ämne: Breda länkar, går det inte göra något åt dom?  (läst 205 gånger)

2019-05-23, 13:02
läst 205 gånger

Utloggad festerman

  • Anbytare ***
  • Antal inlägg: 127
  • Senast inloggad: 2019-06-24, 21:44
  • Staffan Bergh
    • Visa profil
... redan när det postas?

Se till exempel diskussionen om Kerstin Larsdotter här -- eftersom en av deltagarna klistrat in en länk till en sökning i SDHK hos Riksarkivet på det "naiva" (ingen kritik menad!) sätt som gränssnittet inbjuder till, så blir texten för bred för att fungera utan rull-list nertill (nerskalad till 75% i min 24-tums-skärm!)

Det går ju förvisso att undvika: sätt den långa länktexten efter ett lika med i den inledande url-taggen, och skriv något beskrivande inuti:

Kodstycke: [Välj]
[url=https://sok.riksarkivet.se/sdhk?EndastDigitaliserat=false&Innehall=katarina+torsdotter&TrycktUtgava=true&TrycktRegest=true&Brevtext=true&Extratext=true&Sigill=true&Original=true&MedeltidaAvskrifter=true&MedeltidaRegest=true&EftermedeltidaAvskrifter=true&EftermedeltidaRegest=true&AvanceradSok=False&page=1&postid=sdhk_18367&tab=post#tab]Sökning i SDHK@RA efter brev som nämner "Katarina Torsdotter"[/url]
(nu blev den här posten ännu bredare, eftersom SMF inte självmant bryter kod ...)

som blir så här:

Sökning i SDHK@RA efter brev som nämner "Katarina Torsdotter"

men tyvärr är det inte så Infoga länk-knappen funkar. Fast det är så det fungerar på andra ställen (MS Word, ...): man infogar en länk, och en länktext.

mvh /staffan

2019-05-23, 13:14
Svar #1

Utloggad jts

  • Jörgen Tollesson
  • Anbytare *****
  • Antal inlägg: 3165
  • Senast inloggad: 2019-06-24, 23:58
    • Visa profil
    • Arkivguiden med Arkivguidens Forum, Båhus Arkivguide och Göteborgs Arkivguide
Det där är nog ett problem med din webläsare.

För mig ser länken ut som på den bifogade bilden.
Kontakt: http://www.arkivguiden.net/jts.shtml. | Ser gamla inlägg (före april 2016) underliga ut? Argumenterar jag mot mig själv? Saknas något i inläggen? Läs då om orsaken här: http://forum.arkivguiden.net/agf/disk/42626/62869.shtml#post16472.

2019-05-23, 14:01
Svar #2

Utloggad festerman

  • Anbytare ***
  • Antal inlägg: 127
  • Senast inloggad: 2019-06-24, 21:44
  • Staffan Bergh
    • Visa profil
Jo, det är ju möjligt -- men jag använder Chrome, som har nästan 2/3 av marknaden, och ser samma sak i både Edge och Internet Explorer, så det är inte så troligt att det är jag som är en del av en minoritet ...  ;)

Vilken läsare kör du? Funkar länken?

mvh /staffan

2019-05-23, 14:09
Svar #3

Utloggad festerman

  • Anbytare ***
  • Antal inlägg: 127
  • Senast inloggad: 2019-06-24, 21:44
  • Staffan Bergh
    • Visa profil
... och nu har jag kollat ännu närmare, och "mina" web-läsare bryter långa länken efter '?' (frågetecken), men inte efter '&' (ampersand), som Jörgens.

/staffan

2019-05-23, 14:32
Svar #4

Utloggad festerman

  • Anbytare ***
  • Antal inlägg: 127
  • Senast inloggad: 2019-06-24, 21:44
  • Staffan Bergh
    • Visa profil
... och för att gå ytterligare ett steg, så kan jag injicera lite kod i sidan, så funkar det (CSS: word-break: break-word; i lämpligt element, eller lite javascript som lägger till zero width space efter varje ampersand), och kan tänka mej att göra detta för eget bruk
 -- men det löser ju inte alla andras problem (om dom har några?)

mvh /staffan


2019-05-23, 15:32
Svar #5

Utloggad jts

  • Jörgen Tollesson
  • Anbytare *****
  • Antal inlägg: 3165
  • Senast inloggad: 2019-06-24, 23:58
    • Visa profil
    • Arkivguiden med Arkivguidens Forum, Båhus Arkivguide och Göteborgs Arkivguide
Och därmed har vi alltså konstaterat att det är ett webläsarproblem...  :) Hur stor del av marknaden en webläsare har avgör ju inte om den fungerar som den borde...

Själv har jag Pale Moon, och länken fungerar utmärkt.
Kontakt: http://www.arkivguiden.net/jts.shtml. | Ser gamla inlägg (före april 2016) underliga ut? Argumenterar jag mot mig själv? Saknas något i inläggen? Läs då om orsaken här: http://forum.arkivguiden.net/agf/disk/42626/62869.shtml#post16472.

2019-05-23, 16:23
Svar #6

Utloggad festerman

  • Anbytare ***
  • Antal inlägg: 127
  • Senast inloggad: 2019-06-24, 21:44
  • Staffan Bergh
    • Visa profil
Jo, ja, det är det ju sant -- det är ett problem i min, och åtminstone ungefär hälften av alla anbytares, webb-läsare (Chrome + IE +
Edge i Sverige, april i år: Safaris marknadsandel är mycket större i Sverige än i världen i stort. Kan någon Safari-användare där ute testa? :) )

Den enklaste "arbeta-runt"-en (workround), i väntan på att Google och Microsoft fixar problemet (om dom ens håller med om att
det är ett), är att injicera CSS och/eller javaskript i sidan, och det görs bäst på server-sidan ... vi kan ju knappast råda alla
anbytare att göra det på mitt sätt, kan vi?

För övrigt kan jag applicera min fix i min vanliga webb-läsare, men inte på telefonen ... och där är det ännu mer irriterande!

mvh /staffan

 

Annonser



Marknaden

elgenstierna utan-bakgrund 270pxKöp och Sälj

Här kan du köpa eller sälja vidare böcker och andra produkter som är släktforskaren till hjälp.

Se de senast inlagda annonserna